Bug 6435 - Update CoG jar
: Update CoG jar
Status: RESOLVED FIXED
: Java WS Security
Authentication
: unspecified
: PC Windows XP
: P3 normal
: 4.2.2
Assigned To:
:
: 4.0.x
: 6010 6260 6498
: 6425
  Show dependency treegraph
 
Reported: 2008-10-07 11:34 by
Modified: 2008-10-24 16:48 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-10-07 11:34:16
Update CoG jars to the latest with fixes for bugs dependent on this bug.
------- Comment #1 From 2008-10-24 12:50:46 -------
Updated CoG jar with fixes for dependent bugs. Committed to trunk, 4.0 branch
and 4.2 branch.

For 6498, setting the following property will disable requiring authorization
with delegation (with GSI Secure Conversation)

((Stub)port)._setProperty(GSIConstants.AUTHZ_REQUIRED_WITH_DELEGATION,
                             Boolean.FALSE);
------- Comment #2 From 2008-10-24 13:18:22 -------
Will this new JAR replace cog-jglobus.jar in GT4.0.9 and cog-jglobus-1.4.1.jar
in GT4.2.1?  If so, what is the version number of this new JAR and where can I
get a copy (to upgrade CoG jglobus JAR in GridShib)?

Thanks.
------- Comment #3 From 2008-10-24 15:33:49 -------
Yes, the updated jars will be part of next release. You can get the jars from
WSRF code base, here is viewcvs from HEAD and they have version number:

http://viewcvs.globus.org/viewcvs.cgi/wsrf/java/common/source/lib/?pathrev=HEAD

4.0 branch jar will not be tagged until release, but you should get the jar
from WSRF code base.

I am curious: do you actually copy a version of CoG jars? I assumed you just
built against the Java WS Core. 
------- Comment #4 From 2008-10-24 16:48:51 -------
Sorry for reopening this bug previously.  That wasn't necessary.  I wasn't
thinking, I guess.

(In reply to comment #3)
> 
> http://viewcvs.globus.org/viewcvs.cgi/wsrf/java/common/source/lib/?pathrev=HEAD

Thanks, that's exactly what I needed to know.

> I am curious: do you actually copy a version of CoG jars? I assumed you just
> built against the Java WS Core. 

GridShib SAML Tools is completely standalone, nothing else required.  Download,
run 'ant install', done.