Bug 6192

Summary: Apply relevant VDT patches
Product: GRAM Reporter: Stuart Martin <smartin@mcs.anl.gov>
Component: CampaignAssignee: Joe Bester <bester@mcs.anl.gov>
Status: RESOLVED FIXED    
Severity: normal CC: bester@mcs.anl.gov, feller@mcs.anl.gov, rohder@mcs.anl.gov, roy@cs.wisc.edu, smartin@mcs.anl.gov
Priority: P3    
Version: 4.2.0   
Target Milestone: 4.2.1   
Hardware: Macintosh   
OS: All   
Bug Depends on: 1538, 1546, 1548, 1550, 1551, 3036, 4199, 4213, 4617, 4718, 5503, 5976, 5992, 6000, 6036, 6302, 6303, 6304, 6305, 6307    
Bug Blocks:    

Description From 2008-06-26 13:22:33
The set of VDT patches for consideration are listed here:
http://vdt.cs.wisc.edu/patches/1.10.1/

Since VDT already has these patches working with the 4.0.x series, we are
targeting the 4.2.x series for these patches.  Then once VDT moves to 4.2, they
will no longer need to maintain them.

YES (patches to apply)
----------
011__gss_assist_gridmap
    Is this used by EDG/LCG?
013__job_manager_acct
014__gatekeeper_acct
017__lsf_acct.diff
018__script-lsf-queue
    Looks like this patch only adds a commented out line??
019__find-lsf-tools
026__gram_protocol_io
028__gram_job_manager_script
036__gram_job_manager_query
037__gram_job_manager_state
041__jobmanager_syslog
065__prewsgram_multi_condor_log
066__disable_streaming
072__no-gram-reporter
078__gram_jobmanager_filter
088__gram_condor_gratia_patch
089__teragrid-pbs-fixes
096__condor_in_x509_proxy
099__gatekeeper_fork
103__gatekeeper_act
106__jm_grid_monitor_files
108__pr_mp
109__external_openssl
111__openssl_bootstrap
112__pbs_multiple
113__gridftp2
115__bugzilla_3036
117__job_status

NO (OSG specific, do NOT apply)
----
097__osg_grid_globus_location
114__gratia_fqan
    reason: requires gratia perl module that Globus does not have


VERIFY already committed to 4.2.0.
These have already been committed to the 4.0 branch and will be in 4.0.8. 
------------------------------------------
118__xio_0.38
119__bugzilla_6036
120__bugzilla_5992
121__bugzilla_5976
122__bugzilla_6000
123__rft_problem
------- Comment #1 From 2008-06-26 16:14:21 -------
I've put a page on the CDIGS wiki with initial impressions of the patches:
http://confluence.globus.org/display/GRAM/VDT+Patch+Discussion
------- Comment #2 From 2008-07-18 14:35:07 -------
Confirmed the following are already in CVS:
108__pr_mp.diff    
109__external_openssl.diff    
109__external_openssl.diff
113__gridftp2.diff    
115__bugzilla_3036.diff    
118__xio_0.38.diff    
119__bugzilla_6036.diff    
120__bugzilla_5992.diff    
121__bugzilla_5976.diff    
122__bugzilla_6000.diff    
123__rft_problem.diff    

Updating this campaign with links to dependent bugs.
------- Comment #3 From 2008-07-21 10:10:10 -------
(In reply to comment #1)
> I've put a page on the CDIGS wiki with initial impressions of the patches:
> http://confluence.globus.org/display/GRAM/VDT+Patch+Discussion

I clicked on this link, but it requires a name and password. Unfortunately, I
don't see any easy way to sign up for a name and password. Is it meant to be
private?

-alain
------- Comment #4 From 2008-07-21 16:22:01 -------
The GRAM space in confluence is set to be private.

Joe/Stu, if you want to make it public you can move it over to the CDIGS space
by choosing "Edit" on the page and clicking the Edit button on the line below
the title.  It looks like:

Location: GRAM > Home EDIT
------- Comment #5 From 2008-07-30 12:56:27 -------
Committed the following to the bug_6192_branch CVS branch after confirming the
GRAM2 test suite works with fork:
- 013__job_manager_acct.diff
- 014__gatekeeper_acct.diff
- 017__lsf_acct.diff
- 018__script-lsf-queue.diff
- 019__find-lsf-tools.diff
- 026__gram_protocol_io.diff
- 028__gram_job_manager_script.diff
- 036__gram_job_manager_query.diff
- 037__gram_job_manager_state.diff
- 041__jobmanager_syslog.diff
- 066__disable_streaming.diff
- 096__condor_in_x509_proxy.diff
- 099__gatekeeper_fork.diff
- 103__gatekeeper_act.diff
- 106__jm_grid_monitor_files.diff
- 112__pbs_multiple.diff

I will next work on running GRAM4 test suites to see if any of these changes
upset them.
------- Comment #6 From 2008-08-14 06:04:43 -------
I ran the GRAM4 tests yesterday without trouble. Next step will be merging the
patches from the bug_6192_branch to globus_4_2 branch (and trunk).
------- Comment #7 From 2008-08-15 09:13:46 -------
I think everything is applied except for these:

- intrusive patch for something that I think can be handled in a callout
011__gss_assist_gridmap.diff

- conflicts with http://bugzilla.globus.org/bugzilla/show_bug.cgi?id=5820
065__prewsgram_multi_condor_log.diff

- site specific
088__gram_condor_gratia_patch.diff
089__teragrid-pbs-fixes.diff
097__osg_grid_globus_location.diff
114__gratia_fqan.diff
117__job_status.diff

I tested gram2 and gram4 with fork, so the condor, lsf, and pbs changes are not
verified as well as the rest of it. Some of the patches had to be altered to
work because of other changes which occurred since 4.0. I created bugzilla also
tickets for the patches that didn't have them and added them to the dependency
list for this campaign.
------- Comment #8 From 2008-08-15 09:15:42 -------
I forgot to mentioned that those which I committed are also merged to the
trunk.
------- Comment #9 From 2008-08-18 14:30:22 -------
Tested PBS with GRAM2 with these patches as well.
------- Comment #10 From 2008-08-21 19:07:07 -------
Tested condor with GRAM2 with these patches as well. Some failures, but those
were related to command-line arguments with spaces and files not present (known
condor/gram issues).