Bug 295 - text chat dies
: text chat dies
Status: RESOLVED DUPLICATE of bug 77
: Virtual Venues Client Software
Client UI
: CVS
: PC Windows XP
: P2 critical (vote)
: ---
Assigned To:
:
:
:
  Show dependency treegraph
 
Reported: 2003-05-22 11:41 by
Modified: 2003-09-08 10:43 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-05-22 11:41:07
when in a venue, text chat will stop functioning, meaning that no text is sent 
or received, though no error messages are produced.  The only way to make text 
chat work again is to re-enter the venue.

I've found that at the same time it stops functioning, an exception is 
generated:

05/22/03 10:37:13 DEBUG Got read handle=_88781b03_p_globus_io_handle_t 
ret=None  n=4 

05/22/03 10:37:13 DEBUG Data len (351,)
05/22/03 10:37:13 DEBUG register returns _883f3e03_p_callbackStruct
05/22/03 10:37:13 DEBUG Got read handle=_88781b03_p_globus_io_handle_t 
ret=None  n=351 

05/22/03 10:37:13 DEBUG finally read enough data, wait=351 buflen=351
05/22/03 10:37:13 ERROR readcallback failed
Traceback (most recent call last):
  File "C:\Python22\Lib\site-packages\AccessGrid\TextClient.py", line 152, in 
readCallbackWrap
    return self.readCallback(arg, handle, ret, buf, n)
  File "C:\Python22\Lib\site-packages\AccessGrid\TextClient.py", line 190, in 
readCallback
    self.handleData(thedata)
  File "C:\Python22\Lib\site-packages\AccessGrid\TextClient.py", line 246, in 
handleData
    self.Output(event.data)
  File "C:\Python22\Lib\site-packages\AccessGrid\TextClient.py", line 126, in 
Output
    self.textOutCallback(text)
  File "C:\Python22\Lib\site-packages\AccessGrid\VenueClientUIClasses.py", 
line 1892, in OutputText
    message, profile = textPayload.data
ValueError: too many values to unpack

===========================================

Subsequent attempts to send text result in the following lines in the log:

05/22/03 10:44:53 DEBUG VenueClientUIClasses.py: User writes: test
05/22/03 10:44:53 DEBUG EVENT --- Input
05/22/03 10:44:53 DEBUG Text Event: Venue: 
000000f531b834e4008c00dd000b0037d1d, Payload: Sender: None, Recipient: None, 
Private: 0, Data: ('test', <AccessGrid.ClientProfile.ClientProfile instance at 
0x018A0400>)
------- Comment #1 From 2003-05-29 18:52:54 -------
This looks related to two things, the normal struct unpacking mistake (that's 
probably mine), but also the asynch callback stuff.  I'm making it a dup of 
#77 for that reason.

*** This bug has been marked as a duplicate of 77 ***