Bug 174 - AccessGrid/VenueClient.py
: AccessGrid/VenueClient.py
Status: RESOLVED DUPLICATE of bug 77
: Virtual Venue Server Software
Virtual Venue Server
: CVS
: PC Linux
: P2 normal (vote)
: ---
Assigned To:
:
:
:
  Show dependency treegraph
 
Reported: 2003-03-19 11:40 by
Modified: 2003-04-29 09:19 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-03-19 11:40:50
* I had a node service url set without really thinking about it, actually the
default I think, that tried to connect to Ivans node. The connect hung on this
code from AccessGrid/VenueClient.py:

 def EnterVenue(self, URL):
        """
        EnterVenue puts this client into the specified venue.
        """

        haveValidNodeService = 0
        if self.nodeServiceUri != None:
            try:
                Client.Handle( self.nodeServiceUri ).get_proxy().Ping()
		# --- DOES NOT REACH THIS POINT!
                haveValidNodeService = 1    
            except:
                pass

* I also think AccessGrid/VenueClient.py needs logging
------- Comment #1 From 2003-03-24 16:04:35 -------
Ping is something we should be removing I believe, Tom can confirm.
------- Comment #2 From 2003-04-01 11:56:51 -------
Ping has been replaced by Handle.IsValid calls, but the real issue here is that
the SOAP server was in some state where it was still listening, but not
responding.  Clients call in to what appears to be a valid server, and wait
forever (or a long time) for a response.  We need to look into how to detect
connection problems, or time out sooner.
------- Comment #3 From 2003-04-29 09:19:16 -------
This looks like a SOAP client timeout issue. We need to add a client timeout 
after some reasonable duration and address the issue of big requests taking a 
longer amount of time.

*** This bug has been marked as a duplicate of 77 ***