Bug 289

Summary: network config failure
Product: Virtual Venues Client Software Reporter: Robert Olson <olson@mcs.anl.gov>
Component: Client UIAssignee: Robert Olson <olson@mcs.anl.gov>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: P2    
Version: CVS   
Target Milestone: ---   
Hardware: Other   
OS: Windows XP   

Description From 2003-05-15 11:14:31
This isn't really the client UI, but we don't have a category for the 
network config stuff.

Anyway:

C:\home\olson\ag\dev\h2\AccessGrid>python bin\VenueClient.py -d

--------- START VenueClient
My hostname is 192.168.0.16
VerifyExecutionEnvironment: bind to local hostname of 192.168.0.16 fails
This may be due to the hostname being set to something different than the name t
o which the IP address of this computer maps, or to the the hostname not being f
ully qualified with the full domain.

C:\home\olson\ag\dev\h2\AccessGrid>setting flag  536872960
network query raised exception
Traceback (most recent call last):
  File "C:\PROGRA~1\WINGLO~1\config\globus_init.py", line 759, in ThreadQueryFun
c
    self.interfaces = winnet.enumerate_interfaces()
  File "C:\Program Files\WinGlobus\config\winnet.py", line 63, in enumerate_inte
rfaces
    name = reverse_lookup(adapter['ip'], adapter['dns'])
  File "C:\Program Files\WinGlobus\config\winnet.py", line 123, in reverse_looku
p
    res = DNS.Base.DnsRequest(ip_addr, qtype = 'ptr', server = server).req().ans
wers
  File "C:\AccessGridBuild\Globus\pydns-Build\Lib\site-packages\DNS\Base.py", li
ne 173, in req
    self.sendUDPRequest(server)
  File "C:\AccessGridBuild\Globus\pydns-Build\Lib\site-packages\DNS\Base.py", li
ne 193, in sendUDPRequest
    self.response=self.processUDPReply()
  File "C:\AccessGridBuild\Globus\pydns-Build\Lib\site-packages\DNS\Base.py", li
ne 89, in processUDPReply
    raise DNSError, 'Timeout'
DNSError: Timeout
------- Comment #1 From 2003-05-15 11:15:15 -------
This occurred at the lab with GLOBUS_HOSTNAME set to 192.168.0.16.
------- Comment #2 From 2003-07-10 12:38:52 -------

*** This bug has been marked as a duplicate of 315 ***